^start of string
Group 1(c\/|calle|carrer)? ?repeats the group contents below at most once:
cthe literal c (9910 / 1438 / 6316) (case insensitive)
\/the literal / (4710 / 578 / 2F16)
callethe literal text calle (case insensitive) carrerthe literal text carrer (case insensitive) \W?optionally matches any character that is not a Unicode word character
Group 2(\w+\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*(?<!num)) \w+a Unicode word character, repeated at least once
\W?optionally matches any character that is not a Unicode word character
*matches any number of characters from the set below:
A-zone character from A (6510) to z (12210) (case insensitive)
\W?optionally matches any character that is not a Unicode word character
*matches any number of characters from the set below:
A-zone character from A (6510) to z (12210) (case insensitive)
\W?optionally matches any character that is not a Unicode word character
*matches any number of characters from the set below:
A-zone character from A (6510) to z (12210) (case insensitive)
\W?optionally matches any character that is not a Unicode word character
*matches any number of characters from the set below:
A-zone character from A (6510) to z (12210) (case insensitive)
\W?optionally matches any character that is not a Unicode word character
*matches any number of characters from the set below:
A-zone character from A (6510) to z (12210) (case insensitive)
\W?optionally matches any character that is not a Unicode word character
*matches any number of characters from the set below:
A-zone character from A (6510) to z (12210) (case insensitive)
Negative Lookbehind(?<!num) numthe literal text num (case insensitive) \Wany character that is not a Unicode word character
Group 3(nº|num|núm|num\.|núm\.|numero|número|n|n\.|no|no\.)? ?repeats the group contents below at most once:
nºthe literal text nº (case insensitive) numthe literal text num (case insensitive) númthe literal text núm (case insensitive) numthe literal text num (case insensitive) \.the literal . (4610 / 568 / 2E16)
númthe literal text núm (case insensitive) \.the literal . (4610 / 568 / 2E16)
numerothe literal text numero (case insensitive) númerothe literal text número (case insensitive) nthe literal n (11010 / 1568 / 6E16) (case insensitive)
nthe literal n (11010 / 1568 / 6E16) (case insensitive)
\.the literal . (4610 / 568 / 2E16)
nothe literal text no (case insensitive) nothe literal text no (case insensitive) \.the literal . (4610 / 568 / 2E16)
\W?optionally matches any character that is not a Unicode word character
Group 4(\d{1,3}\-?\d{1,3}?) \d{1,3}a Unicode decimal digit, repeated between 1 and 3 times
\-?optionally matches the literal - (4510 / 558 / 2D16)
\d{1,3}?a Unicode decimal digit, repeated between 1 and 3 times
\W?optionally matches any character that is not a Unicode word character
Group 5(bis|dup|mod|ant)? \W+any character that is not a Unicode word character, repeated at least once
\Wany character that is not a Unicode word character
\w+a Unicode word character, repeated at least once
\Wany character that is not a Unicode word character
i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters
g modifier: global. Finds all matches instead of stopping after the first