import re
regex = re.compile(r"^(c\/|calle|carrer)?\W?(\w+\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*(?<!num))\W(nº|num|núm|num\.|núm\.|numero|número|n|n\.|no|no\.)?\W?(\d{1,3}\-?\d{1,3}?)\W?(bis|dup|mod|ant)?\W+(BJ)?\W\w+\W", flags=re.IGNORECASE)
test_str = ("calle Monistrol de la vega num 13-15, BJ1 08012 Barcelona \n"
"calle Monistrol 13, BJ1 08012 Barcelona\n"
"carrer Monistrol 13, BJ1 08012 Barcelona\n"
"Monistrol 13, BJ1 08012 Barcelona\n"
"c/ Monistrol, 13, BJ1 08012 Barcelona\n"
"calle Monistrol nº 13, BJ1 08012 Barcelona\n"
"calle Monistrol 13, bajo 1 08012 Barcelona\n"
"c/ Monistrol 13, Bajo 1º, 08012 Barcelona\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")