re = /.*(https)*\/(.*)\.(.*\?|.*$)(.*$)/m
str = 'https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx'
subst = '$2.$3 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result