$re = '/<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)\">(.|\s)+(<\/xf:if>)/';
$str = '<xf:if is="$post.edit_count && $post.canViewHistory()">
<a href="{{ link(\'posts/history\', $post) }}"
class="actionBar-action actionBar-action--history actionBar-action--menuItem"
data-xf-click="toggle"
data-target="#js-post-{$post.post_id} .js-historyTarget"
data-menu-closer="true">{{ phrase(\'history\') }}</a>
<xf:set var="$hasActionBarMenu" value="{{ true }}" /></xf:if>
<xf:if is="$foo">foo</xf:if>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);