#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?:,\d+)*(?:\.\d+)?"
Local $sString = "mixed string123,456,00indeed" & @CRLF & _
"mixed string123,456.00indeed" & @CRLF & _
"mixed string123,4indeed" & @CRLF & _
"mixed string123,40indeed" & @CRLF & _
"mixed string 1,0" & @CRLF & _
"mixed string 1,00indeed" & @CRLF & _
"mixed string 1,00.00indeed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")