import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\bEXCLUDE\\b.*\\R(*SKIP)(*F)|.+(?:\\R(?!.*\\bEXCLUDE\\b).*)*";
final String string = "First include this line\n"
+ "EXCLUDE this entire line\n"
+ "include this line\n"
+ "and this as single match\n"
+ "and EXCLUDE this line\n"
+ "Lastly include this line";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}