# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:31(\/|-|\.)(?:0?[13578]|1[02]|(?:Jan|Mar|May|Jul|Aug|Oct|Dec)))\1|(?:(?:29|30)(\/|-|\.)(?:0?[1,3-9]|1[0-2]|(?:Jan|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:29(\/|-|\.)(?:0?2|(?:Feb))\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\d|2[0-8])(\/|-|\.)(?:(?:0?[1-9]|(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep))|(?:1[0-2]|(?:Oct|Nov|Dec)))\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$"
test_str = ("Right Ones\n"
"01/01/2000\n"
"1/1/2000\n"
"01/Jan/2000\n"
"31/01/2000\n"
"31/Jan/2000\n"
"31.Jan.2000\n"
"31-Jan-2000\n"
"28/02/2001\n"
"01/1/2000\n"
"01/Jan/2000\n"
"01/1/01\n"
"01/Jan/01\n"
"29/02/2000\n"
"29/Feb/2000\n\n"
"Wrong Ones\n"
"31/04/2000\n"
"29/Feb/2001\n"
"13/13/2000\n"
"30/Feb/2000\n"
"30/Mon/2000\n"
"32/01/2000\n"
"32/Jan/2000\n"
"01/01/2020 #1st Jan\n"
"07/03/2020 #3 July\n"
"12/2/2020 #2 December \n"
"23/4/2020 #23 April ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.