// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*SA.*CV").unwrap();
let string = "MEGA ZAPATO SA DE CV
ALBERTO ESTEBAN MEZA SOL
NET & SERVICES TRANTOR SA DE CV
LAURA YADIRA CEJA PEREZ
CUAUHTEMOC MERCADO BELTRAN
OPERADORA BRASILEÑA SA DE CV
JAIME ALDAIR ROBLES PEREZ
TIENDAS HR SA DE CV
SMARTIUM ACADEMIC GROUP SA DE CV
LA ESPERANZA Y MAS SPR DE RL DE CV
MANUFACTURAS PROINSE S.A DE CV
MAURICIO SANCHEZ GOMEZ
LUIS GERARDO HERNANDEZ ESPINOSA
IMPORTADORA SAMEX SA DE CV
PETROTEKNO SA DE CV
CONDOTEL B NAYAR SA DE CV
GTRES GRUPO EMPRESARIAL SA DE CV
GRUPO INDUSTRIAL RIO RICO S DE RL DE CV
GERARDO GONZALEZ TORRES
ALEJANDRA PASILLAS PERPULY
GRUPO LARA VILLALOBOS SA DE CV
CONSTRUCTORA RAFEGA SA DE CV
DIEGO ARTURO HERNANDEZ GARCIA
RECICLADOS DRAGON SA DE CV
AGRO-IPSA SA DE CV
LOS CUES INMOBILIARIA SA DE CV
ILERICSA SA DE CV
JAVIER ESTRADA SALGADO
JESUS HUMBERTO HERNANDEZ SEGUNDO
TRANSPORTE DE PERSONAL ESPECIALIZADO SA DE CV
IF VERTICAL 2 SAPI DE CV
CIMEIRA S DE RL DE CV
MANAVIL COMERCIALIZADORA SA DE CV
BS DE MEXICO SA DE CV
ARRENDADORA AUTOMOTRIZ HERMES SA DE CV
GD TRAILERS SA DE CV
AVACOR SA DE CV
EFICIENCIA EN SISTEMAS DE ENERGIA RENOVABLE DEL CENTRO SA DE CV
KP EXTRUSION DE MEXICO SA DE CV
SISTEMAS DE CARGA ESPECIALIZADA SA DE CV
ARRENDADORA AUTOMOTRIZ HERMES SA DE CV
SUFERRE DEL BAJIO SA DE CV
SETRIC BEST S DE RL DE CV
AMD MAQUINARIA SA DE CV
MODULAR VANITY TOPS SA DE CV
MII MAVI SA DE CV
CONSTRUSERVICIOS ESL SA DE CV
ANDALUCIA CLINICA DE ESPECIALIDADES SA DE CV
SERVICIOS ESPECIALIZADOS DE INVESTIGACION Y CUSTODIA SA DE CV
RYSE MEDICA SA DE CV
AGROTILENO DE MEXICO SA DE CV
MEDICA SANTA CARMEN SAPI DE CV
ABSTEN DIAGNOSTIK SA DE CV
TLP SERVICIOS SA DE CV
GRUPO ABARMAR SA DE CV
BAJA SUR CONCRETOS SA DE CV
TLP SERVICIOS SA DE CV
GRUPO GARDOMI SA DE CV
PRESTADORES DE SERVICIOS EXTERNOS SA DE CV
FRESH SEASON SA DE CV
SEGURIDAD PRIVADA INTEGRAL MANAVIL SA DE CV
DISEÑOS DE MODA DMC SA DE CV
UNION DE CRIADORES LAS PRADERAS SPR DE RL
INDUSTRIAS SANDOVAL SA DE CV
RLX INVESCO II SA DE CV
HI TEC CONSTRUCCION SA DE CV
VARSAL DISTRIBUCIONES SA DE CV
GUMA DE OCCIDENTE SA DE CV
TYDAN TUBOS Y DERIVADOS DE ACERO DEL NORESTE SA DE CV
NUEVO WKS DOOR SYSTEMS SA DE CV
GC PISOS LASER SA DE CV
BERCALE SERVICES SA DE CV
EURO ALEMANA CAMIONES SA DE CV
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}