import Foundation
let pattern = #"(8|[\+7]){,2}(\-|\s)?(\()?([0-9]{3})(\))?(\-|\s)?[0-9]{2}(\-|\s)?[0-9]{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+79295002639
8 929 500 2639
+7 (929) 500 26-39
8 (929) 500 2639
8-9295002639
8478393
fkjhkhfs75768
+75836fjhgdlhg
[?:+7|8][?:\s|\-]\(?[0-9]{3}\)?[?:\s|\-][0-9]{3}[?:\s|\-][0-9]{2}[?:\s?|\-][0-9]{2}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)