#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\S+\s)?\S*IN\S*(?:\s(?:\(s*\S+\s*(?:,\s*\S+\s*)*\)|\S+))?"
Local $sString = "where c.value IN (3, 4, 5, 6)" & @CRLF & _
"" & @CRLF & _
"where c.value IN (3,4,5,6)" & @CRLF & _
"" & @CRLF & _
"where c.value IN (3)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")