$re = '/(?:\S+\s)?\S*IN\S*(?:\s(?:\(s*\S+\s*(?:,\s*\S+\s*)*\)|\S+))?/';
$str = 'where c.value IN (3, 4, 5, 6)
where c.value IN (3,4,5,6)
where c.value IN (3)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);