$re = '/^(\d*?)(?:, )?([a-zéèàçù -]+?)\n(\d\d ?\d\d\d) ([a-z- ]+?)$/mi';
$str = '61, avenue de Gauthier
81 516 Michel-sur-Paris
6, boulevard de Nguyen
02 998 Techer
boulevard Lucie Bouvet
16 345 Morel-sur-Marques
7, impasse Francois
29172 Deschampsnec
30, place Lucy Guillot
94 786 Texier-sur-Rolland
rue de Pruvost
91 147 Brun
boulevard Amélie Martin
56243 Godard
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);