#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\n(\|?(:? ?---.*?\|)+.*)"
Local $sString = "| Tables | Are | Cool |" & @CRLF & _
"| ------------- |:-------------:| -----:|" & @CRLF & _
"| col 3 is | right-aligned | $1600 |" & @CRLF & _
"| col 2 is | centered | $12 |" & @CRLF & _
"| zebra stripes | are neat | $1 |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")