package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$`)
var str = `# JIRA Board Names
TODO (SI-6):
TODO (SIT-66):
TODO (SITT-666):
TODO (SITTT-6666):
# Different Dash Formats
TODO (SITT—6666):
TODO (SITT–6666):
TODO (SITT-6666):
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}