re = /^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$/m
str = '# JIRA Board Names
TODO (SI-6):
TODO (SIT-66):
TODO (SITT-666):
TODO (SITTT-6666):
# Different Dash Formats
TODO (SITT—6666):
TODO (SITT–6666):
TODO (SITT-6666):
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end