import Foundation
let pattern = #"^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# JIRA Board Names
TODO (SI-6):
TODO (SIT-66):
TODO (SITT-666):
TODO (SITTT-6666):
# Different Dash Formats
TODO (SITT—6666):
TODO (SITT–6666):
TODO (SITT-6666):
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)