use strict;
my $str = 'Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1a b) demanding and 2a a) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1b) demanding and 2b) costly.
It is not supposed to match ( s s 1)
';
my $regex = qr/\b\d[^)]*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}