// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.{1,29})\s").unwrap();
let string = "the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890";
let substitution = "$1, ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}