import Foundation
let pattern = #"//([\w-]+\.)+(\w+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://site.ru
http://assembly.site.com
http://civil-law.site.ru/wist/vved.html
https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"//$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)