#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\\u001b)(8|7|H|>|\[(\?\d+(h|l)|[0-2]?(K|J)|\d*(A|B|C|D\D|E|F|G|g|i|m|n|S|s|T|u)|1000D\d+|\d*;\d*(f|H|r|m)|\d+;\d+;\d+m))"
Local $sString = "\u001b7 \u001b8 \u001bH \u001b>" & @CRLF & _
"" & @CRLF & _
"\u001b[K \u001b[0K \u001b[J \u001b[2J " & @CRLF & _
"\u001b[10A \u001b[10B \u001b[10C \u001b[10D \u001b[10E \u001b[10F" & @CRLF & _
"\u001b[10S \u001b[10T \u001b[10G \u001b[8C \u001b[s \u001b[u \u001b[1000D22" & @CRLF & _
"\u001b[999;999H \u001b[1;1H \u001b[1;1f \u001b[1;24r" & @CRLF & _
"" & @CRLF & _
"\u001b[6n \u001b[5i \u001b[4i \u001b[3g" & @CRLF & _
"" & @CRLF & _
"\u001b[?7h \u001b[?25h \u001b[?25l " & @CRLF & _
"" & @CRLF & _
"\u001b[0m" & @CRLF & _
"\u001b[31m \u001b[41m" & @CRLF & _
"\u001b[1m \u001b[4m \u001b[5m \u001b[7m \u001b[8m" & @CRLF & _
"\u001b[31;1m \u001b[41;1m" & @CRLF & _
"\u001b[38;5;255m \u001b[48;5;255m"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")