#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([A-Za-z]+)\b.*?\s(\d+(?:\.\d+)?)(?!\S)"
Local $sString = "Fluid 13.4" & @CRLF & _
"Fluid 13.4 gm% fluid_haemo 12.0-14.0" & @CRLF & _
"Fluid gm% 13.4 fluid_haemo 12.0-14.0" & @CRLF & _
"Fluid gm% fluid_hameo 12.0-14.0 13.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")