$re = '/^(?!.*\.h\.scss$).*\.scss$/m';
$str = '*.h.scss
*.scss
*.h1.scss
I need a regular expression that match *.scss file name, but didn\'t match the names like *.h.scss. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);