#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<\?.*?>"
Local $sString = "<?xml version='1.0' encoding='utf-8'?>" & @CRLF & _
"<!--" & @CRLF & _
" Licensed to the Apache Software Foundation (ASF) under one or more" & @CRLF & _
" contributor license agreements. See the NOTICE file distributed with" & @CRLF & _
" this work for additional information regarding copyright ownership." & @CRLF & _
" The ASF licenses this file to You under the Apache License, Version 2.0" & @CRLF & _
" (the "License"); you may not use this file except in compliance with" & @CRLF & _
" the License. You may obtain a copy of the License at" & @CRLF & _
"" & @CRLF & _
" http://www.apache.org/licenses/LICENSE-2.0" & @CRLF & _
"" & @CRLF & _
" Unless required by applicable law or agreed to in writing, software" & @CRLF & _
" distributed under the License is distributed on an "AS IS" BASIS," & @CRLF & _
" WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied." & @CRLF & _
" See the License for the specific language governing permissions and" & @CRLF & _
" limitations under the License." & @CRLF & _
"-->" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")