$re = '/(?=.{5,})([а-я]+-{0,1}[а-я]+)/';
$str = 'ааа
аааа
ааааа';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);