#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http://127\.0\.0\.1:5000/countries(?:\?\w+=[\s\w]+(?:&\w+=[\s\w]+)*)?$"
Local $sString = "http://127.0.0.1:5000/x" & @CRLF & _
"http://127.0.0.1:5000/countries?" & @CRLF & _
"http://127.0.0.1:5000/countries?x" & @CRLF & _
"http://127.0.0.1:5000/countries?=" & @CRLF & _
"http://127.0.0.1:5000/countries?x=" & @CRLF & _
"http://127.0.0.1:5000/countries&" & @CRLF & _
"http://127.0.0.1:5000/countries&x" & @CRLF & _
"http://127.0.0.1:5000/countries&=" & @CRLF & _
"http://127.0.0.1:5000/countries&x=" & @CRLF & _
"http://127.0.0.1:5000/countries&x=x" & @CRLF & _
"http://127.0.0.1:5000/countries?code=AU?" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia?x" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia?=" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia?x=" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia?x=x" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia&" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia&x" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia&=" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia&x=" & @CRLF & _
"http://127.0.0.1:5000/countries" & @CRLF & _
"http://127.0.0.1:5000/countries?name=Australia" & @CRLF & _
"http://127.0.0.1:5000/countries?code=AU&name=Australia" & @CRLF & _
"http://127.0.0.1:5000/countries?name=New Zealand&calling_code=64" & @CRLF & _
"http://127.0.0.1:5000/countries?code=AU&name=Australia&capital=Canberra"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")