// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http://127\.0\.0\.1:5000/countries(?:\?\w+=[\s\w]+(?:&\w+=[\s\w]+)*)?$").unwrap();
let string = "http://127.0.0.1:5000/x
http://127.0.0.1:5000/countries?
http://127.0.0.1:5000/countries?x
http://127.0.0.1:5000/countries?=
http://127.0.0.1:5000/countries?x=
http://127.0.0.1:5000/countries&
http://127.0.0.1:5000/countries&x
http://127.0.0.1:5000/countries&=
http://127.0.0.1:5000/countries&x=
http://127.0.0.1:5000/countries&x=x
http://127.0.0.1:5000/countries?code=AU?
http://127.0.0.1:5000/countries?name=Australia?x
http://127.0.0.1:5000/countries?name=Australia?=
http://127.0.0.1:5000/countries?name=Australia?x=
http://127.0.0.1:5000/countries?name=Australia?x=x
http://127.0.0.1:5000/countries?name=Australia&
http://127.0.0.1:5000/countries?name=Australia&x
http://127.0.0.1:5000/countries?name=Australia&=
http://127.0.0.1:5000/countries?name=Australia&x=
http://127.0.0.1:5000/countries
http://127.0.0.1:5000/countries?name=Australia
http://127.0.0.1:5000/countries?code=AU&name=Australia
http://127.0.0.1:5000/countries?name=New Zealand&calling_code=64
http://127.0.0.1:5000/countries?code=AU&name=Australia&capital=Canberra";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}