re = /[a-z]+?\([\-a-z0-9\s]*?\)/m
str = 'rotate(-10 50 100)
translate(-36 45.5)
skewX(40)
scale(1 0.5)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end