#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\<(\w+)\s[^<>]+\>(?!.*\<\/\1\>)"
Local $sString = "<img ng-src=" {{getImageUrl('homeHelp64.jpg')}}" alt="?" width="16" height="16"/>" & @CRLF & _
" <test test-test="test">" & @CRLF & _
" </test>" & @CRLF & _
"</img> // closed" & @CRLF & _
"" & @CRLF & _
"<img ng-src=" {{getImageUrl('homeHelp64.jpg')}}" alt="?" width="16" height="16"/>" & @CRLF & _
" <test test-test="test">" & @CRLF & _
" </test>" & @CRLF & _
" // not closed" & @CRLF & _
"" & @CRLF & _
"// group 1 saves tag name!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")