using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<(\w+)\s[^<>]+\>(?!.*\<\/\1\>)";
string input = @"<img ng-src="" {{getImageUrl('homeHelp64.jpg')}}"" alt=""?"" width=""16"" height=""16""/>
<test test-test=""test"">
</test>
</img> // closed
<img ng-src="" {{getImageUrl('homeHelp64.jpg')}}"" alt=""?"" width=""16"" height=""16""/>
<test test-test=""test"">
</test>
// not closed
// group 1 saves tag name!";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}