$re = '/\<(\w+)\s[^<>]+\>(?!.*\<\/\1\>)/s';
$str = '<img ng-src=" {{getImageUrl(\'homeHelp64.jpg\')}}" alt="?" width="16" height="16"/>
<test test-test="test">
</test>
</img> // closed
<img ng-src=" {{getImageUrl(\'homeHelp64.jpg\')}}" alt="?" width="16" height="16"/>
<test test-test="test">
</test>
// not closed
// group 1 saves tag name!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);