const regex = /((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:token|apikey|secret|client_id): )([a-zA-z0-9\\-]+)\\b', 'gmi')
const str = `entere config here`;
const subst = `$1(removed)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);