re = /.+(\r|\n|$)/m
str = '
1 | ChatGPT | プラグイン | ソフトウェア | チャットボット、自動化 | ChatGPTは、チャットボットと自動化を実現するためのプラグインです。 | 10 | https://t.co/bWvsmYzBLw |
2 | Woldfram | - | - | - | - | - | - |
3 | Zapier | - | - | - | - | - | - |
4 | ChatWithPDF | - | - | - | - | - | - |
5 | SEOapp | - | - | - | - | - | - |
... | ... | ... | ... | ... | ... | ... | ... |
1 | ChatGPT | プラグイン | テクノロジー | チャットボット、プラグイン | ChatGPTは、チャットボットを活用したコミュニケーションを簡単に構築できるサービスです。 | 10 | https://chatgpt.com/ |
2 | Woldfram | プラグイン | テクノロジー | ワークフロー、プラグイン | Woldframは、ワークフローを自動化するためのプラグインサービスです。 | 8 | https://www.woldfram.com/ |
3 | Zapier | プラグイン | テクノロジー | ワークフロー、プラグイン | Zapierは、あらゆるWebサービスを統合するためのプラグインサービスです。 | 8 | https://zapier.com/ |
4 | ChatWithPDF | プラグイン | テクノロジー | チャットボット、PDF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end