# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<![\s\S\r])(---\ntitle:\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\d\D]*---\n\n#\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)/$1$2$3\n\n%%\n```query\nfile: "$2.md" \/\\[\\[(?!.*\\|)([^[\\]]+#[^\\]]+)\\]\\]\/\n```\n%%/gm;t' <<< "---
title: Title can be anything
aliases:
- somealias
tags:
- sometag
topic: sometopic
anotheryamlKey: whatever
date created: 2022-12-14
date modified: 2023-10-06
---
# Title can be anything
First line of file.
Second line. "