# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<![\s\S\r])(---\ntitle:\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\d\D]*---\n\n#\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)"
test_str = ("---\n"
"title: Title can be anything\n"
"aliases:\n"
" - somealias\n"
"tags:\n"
" - sometag\n"
"topic: sometopic\n"
"anotheryamlKey: whatever\n"
"date created: 2022-12-14\n"
"date modified: 2023-10-06\n"
"---\n\n"
"# Title can be anything\n\n"
"First line of file. \n"
"Second line. ")
subst = "$1$2$3\\n\\n%%\\n```query\\nfile: \"$2.md\" /\\\\[\\\\[(?!.*\\\\|)([^[\\\\]]+#[^\\\\]]+)\\\\]\\\\]/\\n```\\n%%"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.