re = /\.(?=[^.]*$)/m
str = 'find the last dot . in this . ridden text . . . really
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end