using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?=\()(?:(?=(?(1).*?(?=\1)).*?\((.*))(?=(?(2).*?(?=\2)).*?\)(.*)).)+?(?>.*?(?=\1))[^(]*?(?=\2$)";
string input = @"Hey! ( (Look,) (ma!) ( (no) r(e(c(u(r)s)i)o)n!! ) ) Woooo
( Matches (can (even
span ) multiple )
lines! ) yeah buddy!!
(((((((()(((((()(((((( NO LIMITS!!! ))))))())))))()))))))))))))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}