re = /({width.+in})/
str = '
jkhdkjfhgkjsdfhk
fdskjglkdfs
{width=kfdjslkgjdflks
dfgdf
in}
sdfkjglkdflgkds'
# Print the match result
str.match(re) do |match|
puts match.to_s
end