package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)ГОСТ\s*\d+\.\d+-\d+`)
var str = `ГОСТ 2.301-68 ЕСКД. Форматы;о наследия (памятниках истории и
культуры) народов
ГОСТ 34.201-89. Информационная технология. Комплекс стандартов на
автоматизированные системы. Виды, комплектность и обозначение документов при
создании автоматизированных систем;
ГОСТ 34.003-90 Информационная технология. Комплекс стандартов на
автоматизированные системы. Термины и определения;
ГОСТ 34.601-90 Информационная технология. Комплекс стандартов на
автоматизированные системы. Автоматизированные системы. Стадии создания;
ГОСТ 34.603-92 Информационная технология. Виды испытаний автоматизированных
систем;РД 50-34.698-90. Методические указания. Информационная технология.
Комплекс стандартов на автоматизированные системы. Автоматизированные
системы. Требования к содержанию документов;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}