use strict;
my $str = 'ГОСТ 2.301-68 ЕСКД. Форматы;о наследия (памятниках истории и
культуры) народов
ГОСТ 34.201-89. Информационная технология. Комплекс стандартов на
автоматизированные системы. Виды, комплектность и обозначение документов при
создании автоматизированных систем;
ГОСТ 34.003-90 Информационная технология. Комплекс стандартов на
автоматизированные системы. Термины и определения;
ГОСТ 34.601-90 Информационная технология. Комплекс стандартов на
автоматизированные системы. Автоматизированные системы. Стадии создания;
ГОСТ 34.603-92 Информационная технология. Виды испытаний автоматизированных
систем;РД 50-34.698-90. Методические указания. Информационная технология.
Комплекс стандартов на автоматизированные системы. Автоматизированные
системы. Требования к содержанию документов;';
my $regex = qr/ГОСТ\s*\d+\.\d+-\d+/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}