import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bPrint\\sName:\\n(?!Print\\sName)(?'guarantor1'[a-zA-Z\\s',.&\\d\\--]+?)(?= \\1$)";
final String string = "Borrower: Guarantor:\n"
+ "{{0_SH}} By: {{1_SH}} (seal)\n"
+ "By: (seal)\n"
+ "Print Name:\n"
+ "Print Name:\n"
+ "Phillip Moore Phillip Moore\n"
+ "Date: {{1_DH}}\n"
+ "2/23/2022\n"
+ "Title: Owner\n"
+ "Date: {{0_DH}}\n"
+ "2/23/2022\n"
+ "12 of 12 (LOC 2020) Borrower Initials {{0_IH}}\n\n"
+ "Borrower: Guarantor:\n"
+ "{{0_SH}} By: {{1_SH}} (seal)\n"
+ "By: (seal)\n"
+ "Print Name:\n"
+ "Print Name:\n"
+ "Phillip test Moore Phillip test Moore\n"
+ "Date: {{1_DH}}\n"
+ "2/23/2022\n"
+ "Title: Owner\n"
+ "Date: {{0_DH}}\n"
+ "2/23/2022\n"
+ "12 of 12 (LOC 2020) Borrower Initials {{0_IH}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}