package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)What is your vendor location\?:\s*(.+)`)
var str = `Your full name (TL submitting form): XXX
What is your vendor location?: Phoenix`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}