const regex = /What is your vendor location\?:\s*(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('What is your vendor location\\?:\\s*(.+)', 'gm')
const str = `Your full name (TL submitting form): XXX
What is your vendor location?: Phoenix`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}