const regex = new RegExp('^((?=[6-9](?<1>){6}|)(?=[3-59](?<1>){3}|)(?=[258](?<1>){2}|)(?=[147](?<1>)|).)+$(?<!(?=(?<-1>.)+(?(1)^))\\11(?=((?<=(?=(?=((?<-2>)(?=.*$((?<-2>\\2)(?<3>)|){9}).)+(?(2)^))(?>(?<-1>)(.)(?=.*$((?<-1>\\1)(?<5>)|){9}))*(?<2>.(?<=((?<5>)(?<-1>\\1)|){9}((?<-1>\\1){10}|())((?<2-1>)(?<-3>\\3)|){9}(?<-9>(?<-1>))?(?<1>){10}(?<-3>)(?<-1>)(?<5>^.*)))+$(?!\\9)(?(3)^)(?<=(?<-5>(?=(?<1>(?=.*$\\5)|.)).)*){10}(\\12)?()|){9}^.*).)*)(?<-13>){2}\\13(?<-13>)^(?<-14>(?(14)|((?<2>(.)?))){10}(?<-15>))+(?<15>)(.)*|^1)', 'gm')
const str = `1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
9971
9973
9977`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}