using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,}[,]\d{3} (W|w)ords)";
string input = @"This is an extremely AU crossover fic that asks the question what might have happened if Petunia Dursley hadn't found a young Harry Potter sleeping on her doorstep on the morning of the 2nd of November 1981. After all, Dumbledore was a bit careless with him 109,446 Words
1,000 words
12,345 words";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}