use strict;
my $str = 'This is an extremely AU crossover fic that asks the question what might have happened if Petunia Dursley hadn\'t found a young Harry Potter sleeping on her doorstep on the morning of the 2nd of November 1981. After all, Dumbledore was a bit careless with him 109,446 Words
1,000 words
12,345 words';
my $regex = qr/(\d{1,}[,]\d{3} (W|w)ords)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}