import re
regex = re.compile(r"\s*<div\sid=\"feature-bullets[\s\S]*?(<li>\s*[\s\S]*?[\s]+<\/ul>)", flags=re.MULTILINE)
test_str = ("<div id=\"feature-bullets\" class=\"a-section a-spacing-medium a-spacing-top-small\">\n\n\n\n\n\n\n\n\n"
" \n"
" \n"
" <ul class=\"a-unordered-list a-vertical a-spacing-none\">\n"
" \n"
" \n\n\n\n"
"<div id=\"hsx-rpp-bullet-fits-message\" class=\"aok-hidden\">\n"
" <div class=\"a-box a-alert-inline a-alert-inline-success hsx-rpp-fitment-bullets\"><div class=\"a-box-inner a-alert-container\"><i class=\"a-icon a-icon-alert\"></i><div class=\"a-alert-content\">\n"
" This fits your <span class=\"hsx-rpp-bullet-model-info\"></span>.\n"
" </div></div></div>\n"
"</div>\n\n\n\n"
"<li id=\"replacementPartsFitmentBullet\" data-doesntfitmessage=\"We're not sure this item fits your \" data-fitsmessage=\"This fits your \" class=\"aok-hidden\"><span class=\"a-list-item\">\n"
" <span id=\"replacementPartsFitmentBulletInner\"> <a class=\"a-link-normal hsx-rpp-fitment-focus\" href=\"#\">Make sure this fits</a>\n"
" <span>by entering your model number.</span>\n"
" </span>\n"
"</span></li>\n\n"
"<script type=\"text/javascript\">\n"
" P.when(\"ReplacementPartsBulletLoader\").execute(function(module){ module.initializeDPX(); })\n"
"</script>\n\n"
" \n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" Precision ground up-cut spiral design\n"
" \n"
" </span></li>\n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" M2 high speed steel runs cooler, lasts longer\n"
" \n"
" </span></li>\n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" Includes sizes 1/4\" x 3\", 1/2\" x 3-1/4\" and 3/8\" x 3\"\n"
" \n"
" </span></li>\n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" 1/4\" shank;\n"
" \n"
" </span></li>\n"
" \n"
" </ul>\n"
" <!-- Loading EDP related metadata -->\n"
" \n"
" \n"
" \n\n"
" \n\n\n\n\n"
"<span class=\"edp-feature-declaration\" data-edp-feature-name=\"featurebullets\" data-edp-asin=\"B006ZBADNW\" data-data-hash=\"2400652208\" data-defects=\"[{"id":"defect-mismatch-info","value":"Different from product"},{"id":"defect-missing-information","value":"Missing information"},{"id":"defect-unessential-info","value":"Unimportant information"},{"id":"defect-other-productinfo-issue","value":"Other"}]\" data-metadata=\"CATALOG\" data-feature-container-id=\"\" data-custom-event-handler=\"\" data-display-name=\"Bullet Points\" data-edit-data-state=\"featureBulletsEDPEditData\" data-position=\"\" data-resolver=\"CQResolver\"></span>\n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n\n"
" \n\n"
" \n"
" \n"
" <span class=\"caretnext\">›</span>\n"
" <a id=\"seeMoreDetailsLink\" class=\"a-link-normal\" href=\"#productDetails\">See more product details</a>\n"
" \n\n"
" \n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")