# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(inn)|([^aeiou\r\n])\2+/$1$2/g;t' <<< "asso
assso
assocco
innasso
inninnasso"