#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\S)(inn)|([^aeiou\r\n])\2+"
Local $sString = "asso" & @CRLF & _
"assso" & @CRLF & _
"assocco" & @CRLF & _
"innasso" & @CRLF & _
"inninnasso"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)