using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(inn)|([^aeiou\r\n])\2+";
string substitution = @"$1$2";
string input = @"asso
assso
assocco
innasso
inninnasso";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}