use strict;
my $str = 'asso
assso
assocco
innasso
inninnasso';
my $regex = qr/(?<!\S)(inn)|([^aeiou\r\n])\2+/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";